Jedox Software Requirements

image_pdfimage_print

Related links: Jedox Hardware Requirements, Platform Support Guide for Jedox Software, Jedox GPU Accelerator Requirements, Jedox SAP Connector Requirements, Jedox Mobile Requirements

Here you will find the software requirements for the following Jedox software: Jedox OLAP Server, Jedox Web, Jedox ETL, Jedox Excel Add-in, and Jedox SAP Connector.

Jedox Server Components (Jedox In-Memory DB Server, Jedox Web, Jedox ETL) 1)
OS
(alternatively)

MS Windows 2)
Windows Server 2008 R2
Windows Server 2012
Windows Server 2012 R2
Windows 7 Service Pack 1 4)
Windows 8
Windows 8.1
Windows 10

Linux 3)
Kernel 2.6.32 or higher

Red Hat EL 6 / CentOS 6 or newer
SUSE LES 11 SP1 or newer
Debian 7 or newer

Browser 5)
(alternatively)

Mozilla Firefox 50+
Microsoft Internet Explorer 11+
Google Chrome 54+

JRE 6)
Java Runtime Environment Version 8
Jedox Excel Add-in 1)
MS Excel
32- and 64-bit versions
2010/2013/2016 7) 8)
Jedox SAP Connector
Connector SAP Java Connector (JCo) version 3.0 or higher 9)

1) For the Jedox components the latest versions of all following Visual Studio runtime packages need to be installed: 2013 and 2015.
Jedox Setup installs Visual Studio components automatically if not executed in silent mode. In case you want to install VCredist manually you can obtain the VCredist packages from: https://support.microsoft.com/en-us/kb/2977003.
Jedox needs additionally .NET Framework (Client Profile) 4.6.1 or newer (if it does not exist, Jedox Setup asks for the permission to download and install .NET Framework).

2) Windows Installer 3.1 or higher must be installed.
All Windows operating systems (except Windows 10) require a specific update to run the VC Redist Installer.
It can be downloaded from https://support.microsoft.com/en-us/kb/2999226.

3) For proper export of reports to PDF files, on Linux the 32-bit versions of the following libraries have to be installed, even if the system itself is 64-bit (see Additional Requirements for Linux):

  • GNU C library (glibc)
  • GNU Standard C++ library (libstdc++)
  • FreeType
  • Fontconfig

4) For Windows 7 SP1, we recommend that you perform all updates prior to Jedox installation.

5) Starting with Jedox Suite Version 3.3 a message is displayed for unsupported browsers. Linux versions of the browsers are not officially supported.

6) Only Java Runtime Environment versions of Oracle are supported. Java is needed for Apache Tomcat, which is used for the components Integrator, Scheduler, and Fopper.
If Java Runtime Environment does not exist, then the Jedox Windows Setup prompts you for permission to download and install it.
As of Version 7.0 SR2 Java Runtime Environment is shipped with Jedox Linux Setup. Linux Setup versions before need an internet connection (7.0 SR1) or an existing installation of this software (7.0).
If an update or a change of the JAVA installation is needed, please read first the knowledge base article “About Java Installation Updates and Changes”.

7) To see the Jedox menu in Excel 2010/2013/2016, you must first install the MS Office VBA components.

8) The version Microsoft Click to Run is not supported.

9) SAP JCo is available from SAP AG at the SAP Service Marketplace.

 

image_pdfimage_print
Was this post helpful?
NoYes (+1 rating, 1 votes)
Loading...